System Requirements

For this CME program, your computer needs to have Internet Explorer 6.0 (or higher) or Mozilla Firefox 2 (or higher) or Safari 2 (or higher) and Adobe Flash Player 9.0 (or higher). If you are using a modem to connect to the Internet, you will need a modem speed of at least 56K to view the pages of the site. Video content requires DSL and higher. Adobe Flash Player is required to complete the self-assessment and Adobe Reader is required to print your certificate. You can download Adobe Reader for free. As you will be printing your CME certificate online, your computer must be connected to a printer.

 

 

 

 

Board ReviewSAMs PrepAAFP Live!

Latest Podcasts
 
Stay Current
If not registered enter your email